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Introduction to the  
Integrative Genomics Viewer (IGV) 

Did	
  you	
  follow	
  the	
  instruc2ons	
  in	
  the	
  pre-­‐workshop	
  fact	
  sheet?	
  

If	
  not,	
  go	
  to	
  www.igv.org/workshops/ASHG2016	
  

1.  Download	
  the	
  workshop	
  data:	
  Exercises.zip	
  
2.  If	
  you	
  do	
  not	
  have	
  IGV	
  installed,	
  see:	
  DownloadAndLaunch.pdf	
  	
  
3.  If	
  you	
  have	
  not	
  used	
  IGV	
  before,	
  see:	
  BasicsExercise.pdf	
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Disclosure	
  for:	
  
	
  

ASHG	
  Interac2ve	
  Workshop:	
  	
  
Introduc2on	
  to	
  the	
  	
  

Integra2ve	
  Genomics	
  Viewer	
  (IGV)	
  
	
  
	
  
	
  
	
  

	
  

No	
  relevant	
  conflicts	
  to	
  disclose	
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Epigenomics	
  

Variants	
  and	
  genotypes	
  Copy	
  number	
  

Microarray	
  gene	
  expression	
  
NGS	
  alignments	
  

RNA-­‐seq	
  

Gene	
  annota?ons	
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IGV data sources: File formats 
•  IGV supports many different file formats.  

 
•  For more info see: www.broadinstitute.org/igv/FileFormats 
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integrated  
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Local	
  files	
  
HTTP	
  server	
  

FTP	
  server	
   GenomeSpace	
  

•  View local files without uploading. 
•  View remote files without downloading whole dataset. 

IGV data sources 



The Broad Institute of MIT and Harvard The Broad Institute of MIT and Harvard The Broad Institute of MIT and Harvard 

Interactive  
visual exploration of  
integrated  
genomic data 
 

IGV 



The Broad Institute of MIT and Harvard The Broad Institute of MIT and Harvard The Broad Institute of MIT and Harvard 

Interactive  
visual exploration of  
integrated  
genomic data 

IGV 



The Broad Institute of MIT and Harvard The Broad Institute of MIT and Harvard The Broad Institute of MIT and Harvard 

Interactive  
visual exploration of  
integrated  
genomic data 

IGV 



The Broad Institute of MIT and Harvard The Broad Institute of MIT and Harvard The Broad Institute of MIT and Harvard 

www.igv.org	
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Desktop	
  
applicaHon	
  

www.igv.org	
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www.broadinsHtute.org/igv	
  



The Broad Institute of MIT and Harvard The Broad Institute of MIT and Harvard The Broad Institute of MIT and Harvard 

JavaScript	
  
version	
  

www.igv.org	
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Desktop	
  
applicaHon	
  

www.igv.org	
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Using IGV: The Basics 
Review of pre-workshop exercise 
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Download and launch IGV 
1	
   Go	
  to	
  www.igv.org	
  and	
  click	
  on	
  

2	
  

3	
  

or	
  

or	
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Select the reference genome 

4	
  
The	
  genome	
  drop-­‐down	
  menu	
  is	
  
in	
  the	
  upper	
  leP	
  corner	
  

Select	
  Human	
  hg18	
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Select the reference genome 

4	
  
The	
  genome	
  drop-­‐down	
  menu	
  is	
  
in	
  the	
  upper	
  leP	
  corner	
  

Select	
  Human	
  hg18	
  

The	
  genome	
  menu	
  is	
  short	
  when	
  you	
  first	
  install	
  IGV.	
  

But	
  IGV	
  hosts	
  dozens	
  of	
  genomes	
  and	
  allows	
  you	
  to	
  load	
  
other	
  genomes	
  too.	
  

More	
  about	
  that	
  later	
  ….	
  

                   THERE’S MORE TO REFERENCE GENOMES	
  !	
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Load data 
5	
  

6	
  

✔	
  

select	
  

open	
  

select	
  

and	
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Load data 
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Navigate 

Zoom	
  in	
  /	
  out	
   From whole genome view 
to base pair resolution 

Scroll	
  /	
  pan	
   View neighboring regions 

Jump	
  to	
  locus	
   Enter coordinates or name 
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Navigate 

Whole 
genome 
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Navigate 

Whole 
genome 

Base pair 
resolution 
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Navigate 

select	
   enter	
  or	
   click	
  or	
  View	
  whole	
  
chromosome	
  

View	
  whole	
  
genome	
  

select	
   click	
  or	
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Navigate 
Zoom	
  in	
  to	
  

area	
  swept	
  out	
  
in	
  ruler	
  	
  

click	
  &	
  drag	
  

Zoom	
  in	
  on	
  area	
  
of	
  interest	
  

double-­‐click	
  

alt-­‐click	
  

Zoom	
  out	
  

Zoom	
  in	
  or	
  out	
  using	
  the	
  
“railroad	
  track”	
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Navigate 

Click anywhere in the 
data panel and drag 
tracks left and right 
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Navigate 

Type gene name or other 
RefSeq annotation into the 
Search Box and click Go 

Or enter a region: 
<chr>:<start>-<end> 
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More options for reference genomes 
1. Click on More in the 
genome dropdown menu 
to see complete list of 
hosted genomes 
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More options for reference genomes 
1. Click on More in the 
genome dropdown menu 
to see complete list of 
hosted genomes 

2. Select entry from the list 
to load genome and add to 
the dropdown menu 
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More options for reference genomes 
Genomes	
  menu	
  

Load From File or  
Load From URL 
Load genome from 
indexed FASTA file 
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Reference sequence 

By	
  default	
  the	
  sequence	
  for	
  the	
  forward	
  strand	
  is	
  shown.	
  

Click	
  anywhere	
  on	
  the	
  sequence	
  to	
  see	
  a	
  3	
  frame	
  transla2on.	
  

Click	
  the	
  arrow	
  on	
  the	
  leP	
  to	
  reverse	
  the	
  strand.	
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Viewing multiple regions 
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Viewing Next Generation 
Sequencing (NGS) Data 
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Viewing alignments 
Whole chromosome view 

Zoom in to see alignments 
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Zoom in to view alignments 

Viewing alignments 

Aligned 
reads 

Coverage 
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Viewing alignments 
Zoom in to see more detail 

Bases that do not match 
the reference sequence 
are highlighted by color 
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Viewing alignments 

Coverage track indicates 
loci with large number of 

mismatches 
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Viewing alignments 
Zoom in to see more detail 
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Viewing alignments 

Read mapping quality = 0 
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Viewing alignments 
Zoom in to see more detail 

Low-quality base calls are 
faint, semi-transparent. 
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Viewing alignments 

How far do you need to        
zoom in to see the alignments? 

30 
kb 

-or- Set a different 
threshold in Preferences 

	
  
• 	
  Higher	
  value	
  è	
  requires	
  more	
  memory	
  	
  
• 	
  Low	
  coverage	
  files	
  è	
  ok	
  to	
  use	
  higher	
  value	
  	
  	
  	
  
• 	
  Very	
  deep	
  coverage	
  files	
  è	
  use	
  lower	
  value	
  
	
  	
  	
  	
  

Zoom in to view alignments 
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Viewing alignments 

or limit the depth 

For	
  very	
  deep	
  coverage	
  files:	
  use	
  low	
  visibility	
  threshold	
  value	
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Viewing alignments 

down-
sampled 
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•  Load alignments from whole genome sequencing 
•  View sites where SNPs were called 
•  Sort and color to highlight patterns 

Viewing SNPs: Exercise 

Hands-on 

Data	
  for	
  today’s	
  exercises:	
  
	
  www.igv.org/workshops/ASHG2016/Exercises.zip	
  

	
  
InstrucHons	
  for	
  downloading	
  and	
  launching	
  IGV:	
  

	
  www.igv.org/workshops/ASHG2016/DownloadAndLaunch.pdf	
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Viewing SNPs: Exercise 

For a larger data panel: 
Click & drag the window divider 

To modify the info popup behavior: 
Click yellow balloon icon in toolbar 



The Broad Institute of MIT and Harvard The Broad Institute of MIT and Harvard The Broad Institute of MIT and Harvard 

Viewing SNPs: www.igv.org/workshops/ASHG2016/ExInstr.pdf 
Initialize exercise: 1	
  

Go to first putative SNP locus:     Type  snp1  in the search box and click Go.  

- Click & drag on alignments to put the column of red T’s between the centerlines. 
- Right-click on alignments, and select Sort alignments by > base. 

Does this look like a true SNP?  

2	
  

3	
  

4	
  

5	
  

6	
  

Go to next putative SNP locus:     Type  snp2  in the search box and click Go.  

- Click & drag on alignments to position the 5 blue C’s between the centerlines. 
- Right-click on alignments, and deselect Shade base by > quality. 

+ select Color alignments by > read strand. 
+ select Sort alignments by > read strand. 

For more info, mouse over the red & blue 
bar in the coverage track.  

Does this look like a true SNP?  Note this was not from a strand preserving library. 7	
  

Click File > Open Session. Go to the folder where you downloaded 
the workshop data and select snps / snp_session.xml. 



The Broad Institute of MIT and Harvard The Broad Institute of MIT and Harvard The Broad Institute of MIT and Harvard 

Viewing SNPs: Initialize the exercise 

•  Click	
  File	
  >	
  Open	
  Session	
  
•  Navigate	
  to	
  the	
  folder	
  where	
  you	
  downloaded	
  the	
  workshop	
  data	
  –	
  

and	
  select	
  snps	
  /	
  snp_session.xml	
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Viewing SNPs 
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Viewing SNPs 

Type “snp1” in the Search Box and click Go 

• Navigate to first putative SNP locus 
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Viewing SNPs 
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Viewing SNPs 
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Viewing SNPs 

Click & drag to 
position mismatched 
bases between the 
center guidelines 
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Viewing SNPs 

Right-click on alignments and select 
Sort alignments by > base 

On Mac:  
Right-click = Control-click 



The Broad Institute of MIT and Harvard The Broad Institute of MIT and Harvard The Broad Institute of MIT and Harvard 

Viewing SNPs 
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Viewing SNPs 

Mouse over red & blue bar in coverage track. 
Note allele counts and frequencies.  
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Viewing SNPs 
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Viewing SNPs 

Type “snp2” in the Search Box 
and click Go 
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Viewing SNPs 

NOTE:	
  Large	
  %	
  of	
  low	
  quality	
  base	
  calls,	
  and	
  
scader	
  of	
  “C”	
  mismatches	
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Viewing SNPs 

Click & drag to 
position locus with 
5 blue C’s between 
center guidelines 



The Broad Institute of MIT and Harvard The Broad Institute of MIT and Harvard The Broad Institute of MIT and Harvard 

Viewing SNPs 

Right-click on alignments and deselect 
Shade base by quality 
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Viewing SNPs 
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Viewing SNPs 

Right-click on alignments and select 
Sort alignments by > read strand 
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Viewing SNPs 

Right-click on alignments and select 
Color alignments by > read strand 
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Viewing SNPs 
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Viewing SNPs 

Reset the color option: 
Right-click on alignments and select 
Color alignments by >  
insert size and pair orientation 
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Viewing RNA-seq Data 
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RNA-seq 

hdp://en.wikipedia.org/wiki/RNA-­‐Seq#Gene_expression	
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RNA-seq 

hdp://en.wikipedia.org/wiki/RNA-­‐Seq#Gene_expression	
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RNA-seq alignments 
 
 

Read spanning 
splice junction 
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RNA-seq alignments 
 
 •  Splice junction track 
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RNA-seq alignments 
 
 •  Splice junction track 

 
Arcs represent reads that 
span exon junctions 
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RNA-seq alignments 
 
 •  Splice junction track 

 
Height is proportional 
to # of reads 
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RNA-seq alignments 
 
 •  Splice junction track 

Many reads connecting 
these exons 
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RNA-seq alignments 
 
 •  Splice junction track 

 

Relatively few 
spanning to this exon 
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RNA-seq alignments 
 
 

Sashimi plot 
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RNA-seq alignments 
 
 

Arcs represent 
reads that span 
exon junctions 

Sashimi plot 
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RNA-seq alignments 
 
 

Numbers are 
read counts 

Sashimi plot 
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RNA-seq alignments 
 
 

Peaks represent 
coverage within exon 
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Sashimi plot 
 
 Viewing	
  RNA	
  splicing	
  with	
  Sashimi	
  Plots	
  
	
  
Reference:	
  	
  
	
  

Katz	
  	
  et	
  al.	
  
Quan?ta?ve	
  visualiza?on	
  of	
  alterna?ve	
  exon	
  expression	
  
from	
  RNA-­‐seq	
  data	
  
Bioinforma2cs	
  (2015)	
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RNA-seq: Exercise 
 
 

•  Examine	
  2ssue-­‐specific	
  alterna2ve	
  splicing.	
  

•  Data:	
  	
  Illumina	
  BodyMap	
  2.0	
  	
  
	
  
hdp://portals.broadins2tute.org/genome_bio/human_lincrnas/	
  

Hands-on 
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RNA-seq: Exercise 
 
 

1.  Enable	
  Splice	
  Junc2on	
  track	
  in	
  IGV	
  Preferences	
  
	
  
2.  Load	
  BodyMap	
  alignments	
  

3.  View	
  splice	
  junc2on	
  track	
  

4.  View	
  Sashimi	
  plot	
  

Steps   
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RNA-seq: www.igv.org/workshops/ASHG2016/ExInstr.pdf 

1	
  

Observe the two samples: Heart and Liver. 
Each sample has a coverage track, splice junction track, and the RNA-seq reads. 2	
  

3	
  

5	
  

- Click View > Preferences, select the Alignments tab, 
check Splice Junction Track, and click OK. 

- Click File > Open Session. Go to the folder where you downloaded 
the workshop data and select rna / rna_session.xml. 

- Right click on the Genes track, and select Squished to display the isoforms. 
- Zoom in to get a closer view of the first 4 exons of the gene. 

4	
  
Note differences in the heart vs. liver samples and 
how they compare to the gene isoforms.  

Observe evidence of 
alternative splicing: 

Initialize exercise: 

- Right click on the data (reads or junction track) and select Sashimi Plot. 
-  In the track selection window that pops up, make sure both tracks are selected. 

6	
   Sashimi Plot: The Sashimi Plot pops up in a separate window. 
Note it is interactive: Zoom in and out. Pan. Right-click to set options.  
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Select View > Preferences…  
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Click Alignments tab 
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Select Splice Junction Track 
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Click OK to save changes 
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•  Navigate	
  to	
  the	
  folder	
  where	
  you	
  
downloaded	
  the	
  workshop	
  data,	
  and	
  
select	
  rna	
  /	
  rna_session.xml	
  

•  Click	
  File	
  >	
  Open	
  Session	
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Heart 

Liver 
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Coverage 
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Junction Coverage 



The Broad Institute of MIT and Harvard The Broad Institute of MIT and Harvard The Broad Institute of MIT and Harvard 

 
 

Right-click over 
RefSeq Genes 
track 
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Select Squished 
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Isoforms now 
displayed 
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Evidence of 
alternative 
splicing 



The Broad Institute of MIT and Harvard The Broad Institute of MIT and Harvard The Broad Institute of MIT and Harvard 

 
 

Right-click and 
select Sashimi Plot 
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Leave both tracks 
selected and click OK 
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Viewing Structural Events 
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Structural events 
 
 •  Structural	
  events	
  include	
  dele2ons,	
  duplica2ons,	
  transloca2ons,	
  

and	
  inversions.	
  	
  

•  Paired	
  reads	
  can	
  yield	
  evidence	
  of	
  structural	
  events.	
  

•  Alignment	
  coloring	
  op2ons	
  help	
  highlight	
  these	
  events	
  based	
  on:	
  

•  Inferred	
  insert	
  size	
  (template	
  length)	
  

•  Pair	
  orienta2on	
  (rela2ve	
  strand	
  of	
  pair)	
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Paired-end sequencing 
 
 

Read from 
each end 

Fragment 

DNA or 
cDNA 

Insert size 
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Paired-end sequencing 
 
 

Align to 
Reference 

Read from 
each end 

Fragment 

DNA or 
cDNA 

F	
   R	
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Paired-end sequencing 
 
 

Inferred insert size 

Align to 
Reference 

Read from 
each end 

Fragment 

DNA or 
cDNA 

F	
   R	
  

Insert size (template length) 
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Interpreting Insert Size 
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Interpreting inferred insert size 

The	
  “inferred	
  insert	
  size”	
  can	
  be	
  used	
  to	
  detect	
  
evidence	
  of	
  structural	
  variants,	
  including	
  

•  Dele2ons	
  
•  Inser2ons	
  
•  Inter-­‐chromosomal	
  rearrangements	
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Deletion 
 
 

What	
  is	
  the	
  effect	
  of	
  a	
  dele2on	
  	
  
on	
  inferred	
  insert	
  size?	
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Deletion 
 
 

Reference 
Genome 
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Deletion 
 
 

Reference 
Genome 

Subject 
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Deletion 
 
 

Reference 
Genome 

Subject 
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Deletion 
 
 

Reference 
Genome 

Subject 
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Deletion 
 
 

Reference 
Genome 

Subject 
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Deletion 
 
 

Reference 
Genome 

Subject 
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Deletion 
 
 

Reference 
Genome 

Subject 
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Deletion 
 
 

Reference 
Genome 

Subject 

Inferred insert size 
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Deletion 
 
 

Reference 
Genome 

Subject 

Inferred insert size 

Expected insert size 
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Deletion 
 
 

Reference 
Genome 

Subject 

Inferred insert size 

Expected insert size 

Inferred insert size is greater than expected value 
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Deletion 

Pairs with larger than expected 
insert size are colored red. 



The Broad Institute of MIT and Harvard The Broad Institute of MIT and Harvard The Broad Institute of MIT and Harvard 

Deletion 

Note drop in coverage   
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Insert size color scheme 

	
  
•  Smaller	
  than	
  expected	
  insert	
  size:	
  

•  Larger	
  than	
  expected	
  insert	
  size:	
  

•  Pairs	
  on	
  different	
  chromosomes:	
  

	
  	
  	
  	
  	
  Each	
  end	
  colored	
  by	
  chromosome	
  of	
  its	
  mate	
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Rearrangement 

TUMOR	
  

CHR	
  6	
  CHR	
  1	
  

Split-screen view 

NORMAL	
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Rearrangement 

TUMOR	
  

CHR	
  6	
  CHR	
  1	
  

NORMAL	
  

Color 
indicates 
mate is 
on chr 1 

No similar 
evidence in 
the normal 
sample 

Color 
indicates 
mate is 
on chr 6 
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Interpreting Pair Orientations 
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Interpreting pair orientations 

Orientation of paired reads can reveal  
evidence of structural events, including: 

•  Inversions 
• Duplications 
• Translocations 
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Inversion 
 
 

Reference 
Genome 



The Broad Institute of MIT and Harvard The Broad Institute of MIT and Harvard The Broad Institute of MIT and Harvard 

Inversion 
 
 

A B 
Reference 
Genome 
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Inversion 
 
 

Reference 
Genome A B 

B A 
Subject 
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Inversion 
 
 

Reference 
Genome A B 

B A 
Subject 
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Inversion 
 
 

Reference 
Genome A B 

B A 
Subject 
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Inversion 
 
 

Reference 
Genome A B 

B A 
Subject 
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Inversion 
 
 

Reference 
Genome A B 

B A 
Subject 

F	
   R	
  

F	
   F	
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Inversion 
 
 

Reference 
Genome A B 

B A 
Subject 
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Inversion 
 
 

Reference 
Genome A B 

B A 
Subject 
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Inversion 
 
 

Reference 
Genome A B 

B A 
Subject 
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Inversion 
 
 

Reference 
Genome A B 

B A 
Subject 

R	
   R	
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Inversion 
 
 

Reference 
Genome A B 

F	
  
R	
  

F	
  
R	
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Inversion 
 
 

Reference 
Genome A B 

F	
  
R	
  

F	
  
R	
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Color by pair orientation 
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Inversion 
 
 



The Broad Institute of MIT and Harvard The Broad Institute of MIT and Harvard The Broad Institute of MIT and Harvard 

Inversion 
 
 Note drop in coverage at breakpoints   
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Hands on 
 
 Use	
  color	
  and	
  viewing	
  op2ons	
  to	
  examine	
  an	
  inversion	
  
	
  
Data	
  from	
  1000	
  Genomes	
  

	
  hdp://www.interna2onalgenome.org/	
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Structural events: igv.org/workshops/ASHG2016/ExInstr.pdf 

1	
  

Observe colorful alignments. By default color mode = By insert size and pair orientation 2	
  

3	
  

- Click File > Open Session. Go to the folder where you downloaded 
the workshop data and select svs / svs_session.xml. 

- Right-click over alignments and select Color alignments by > insert size. 
Observe: changes in color. 

- Right-click over alignments and select Color alignments by > pair orientation. 
Observe: most of the initial colorful alignments are now lit up again. 

- Right-click over alignments and select View as pairs. 
 

 
4	
  

High % of forward-forward pairs and 
reverse-reverse pairs at the same locus 

Observe evidence 
of inversion: 

Initialize exercise: 
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Click	
  File	
  >	
  Open	
  Session	
   Navigate	
  to	
  the	
  folder	
  where	
  you	
  
downloaded	
  the	
  workshop	
  data,	
  and	
  
select	
  svs	
  /	
  svs_session.xml	
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Viewing Structural Events  new
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Third Gen Sequencing 
 
 

•  Applica2ons	
  	
  
–	
  structural	
  variants,	
  long-­‐range	
  haplotype	
  phasing,	
   	
   	
  

	
  de	
  novo	
  assembly,	
  	
  …	
  

•  Long	
  reads:	
  	
  	
  
~10,000	
  bp	
  up	
  to	
  ~100,00	
  bp	
  

•  High	
  raw	
  error	
  rate	
  in	
  individual	
  reads	
  	
  
(high	
  consensus	
  accuracy	
  with	
  sufficient	
  coverage)	
  

•  Plaqorms:	
  	
  
–	
  PacBio,	
  Oxford	
  Nanopore,	
  10X,	
  	
  Illumina	
  Tru-­‐Seq,	
  	
  …	
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IGV Enhancements 
 
 •  Filtering	
  raw	
  errors	
  to	
  reveal	
  consensus	
  variants	
  

•  Extended	
  support	
  for	
  split	
  alignments	
  
•  Linking	
  split	
  reads	
  
•  Support	
  for	
  “SA”	
  tag	
  

•  Support	
  for	
  barcoded	
  alignments	
  (10X,	
  	
  Illumina	
  Tru-­‐seq)	
  

•  Improved	
  performance	
  for	
  wide	
  range	
  views	
  (100kb	
  -­‐	
  500kb)	
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Filtering raw errors – small indels 
 
 

PACBIO	
  

ILLUMINA	
  

Aaron	
  Wenger,	
  PacBio	
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Filtering raw errors - indels 
 
 

	
  

PACBIO	
  

ILLUMINA	
  

Aaron	
  Wenger,	
  PacBio	
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Filtering raw errors - nucleotides 
 
 

PACBIO	
  

Nucleo2de	
  mismatches	
  
shown	
  at	
  low	
  zoom	
  (new)	
  

ILLUMINA	
  

Aaron	
  Wenger,	
  PacBio	
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Filtering raw errors - nucleotides 

PACBIO	
  

“Quick	
  consensus”	
  mode	
  

ILLUMINA	
  

Aaron	
  Wenger,	
  PacBio	
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Structural variant example - deletion 
 
 

PACBIO	
  

ILLUMINA	
  

Aaron	
  Wenger,	
  PacBio	
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3rd gen support enabled in preferences 
 
 

	
  

View	
  >	
  Preferences	
  
Alignments	
  tab	
  

Only	
  show	
  consistent	
  
mismatches	
  

Hide	
  small	
  indels	
  

Purple	
  inser2on	
  labels	
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10X 

View	
  linked	
  reads	
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10X 

	
  
Haplotype	
  “1”	
  

Haplotype	
  “2”	
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Availability   

•  Features	
  available	
  now	
  in	
  development	
  version	
  of	
  IGV	
  
broadins2tute.org/igv/download_snapshot	
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Viewing Variants 
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Viewing variants (VCF files) 

Variant	
  Call	
  Format	
  (VCF):	
  	
  	
  
File	
  format	
  for	
  encoding	
  variant	
  sites	
  and	
  genotypes	
  
	
  
hdp://www.interna2onalgenome.org/wiki/Analysis/variant-­‐call-­‐format	
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Viewing variants (VCF files) 
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Variant	
  sites	
  

Genotypes	
  Sample	
  
informa2on	
  

Viewing variants (VCF files) 
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Viewing variants (VCF files) 
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Zoom	
  in	
  here	
  

Viewing variants (VCF files) 
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Viewing variants (VCF files) 
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Red	
  =	
  alternate	
  allele	
  
Blue	
  =	
  reference	
  allele	
  

Viewing variants (VCF files) 
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Viewing variants (VCF files) 
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Cyan	
  =	
  homozygous	
  
Blue	
  =	
  heterozygous	
  
Grey	
  =	
  reference	
  

Viewing variants (VCF files) 
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Viewing variants (VCF files) 
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Sample	
  informaHon	
  
	
  -­‐	
  Meta	
  data	
  on	
  samples.	
  	
  
	
  -­‐	
  Used	
  for	
  sor2ng	
  &	
  grouping	
  

In	
  this	
  example:	
  	
  
•  sample	
  
•  pop	
  
•  super_pop	
  
•  gender	
  

Viewing variants (VCF files) 
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Sample information 

Sample	
  informa2on	
  is	
  defined	
  in	
  an	
  auxiliary	
  tab-­‐delimited	
  file.	
  
	
  
•  First	
  row	
  defines	
  column	
  names	
  

•  First	
  column	
  contains	
  sample	
  names	
  (must	
  match	
  VCF	
  sample	
  names)	
  
	
  
Example:	
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Hands on: Viewing variants (VCF file) 

Reference:	
  	
  	
  
	
  
Giulio	
  Genovese	
  et	
  al.	
  
	
  Associa4on	
  of	
  Trypanoly4c	
  ApoL1	
  Variants	
  with	
  Kidney	
  Disease	
  
in	
  African	
  Americans,	
  
Science	
  329,	
  841	
  (2010);	
  DOI:	
  10.1126/science.1193032	
  

Use	
  sample	
  informa4on	
  to	
  examine	
  a	
  variant	
  that	
  
segregates	
  by	
  popula4on.	
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Viewing variants: www.igv.org/workshops/ASHG2016/ExInstr.pdf 

1	
  

Observe the two data panels: Variant sites (upper panel) and Genotypes (lower panel). 2	
  

3	
  

- Click File > Open Session. Go to the folder where you downloaded 
the workshop data and select vcf / vcf_session.xml. 

- Type  APOL1:S342G  in the search box and click Go. 
- Right-click over genotypes and select Display Mode > Squished. 
- Right-click over genotypes and select Group By, and select attribute super_pop. 
- Scroll down to see all the groups 

4	
  
Variants not present in some population groups 
and prevalent in others.  

Observe differences 
between groups: 

Initialize exercise: 
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Hands on: Viewing variants (VCF file) 

Click	
  File	
  >	
  Open	
  Session	
   Navigate	
  to	
  the	
  folder	
  where	
  you	
  
downloaded	
  the	
  workshop	
  data,	
  
and	
  select	
  vcf	
  /	
  vcf_session.xml	
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Hands on: Viewing variants (VCF file) 
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APOL1: S342G 

In	
  the	
  search	
  box	
  enter	
  
APOL1:S342G	
  and	
  click	
  
Go	
  

Hands on: Viewing variants (VCF file) 
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Hands on: Viewing variants (VCF file) 
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Right-­‐click	
  over	
  genotypes	
  and	
  select	
  
Display	
  Mode	
  >	
  Squished	
  

Hands on: Viewing variants (VCF file) 



Th
e 
im
agThe Broad Institute of MIT and Harvard Th

e 
im
agThe Broad Institute of MIT and Harvard Th

e 
im
agThe Broad Institute of MIT and Harvard 

Hands on: Viewing variants (VCF file) 
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Right-­‐click	
  over	
  genotypes	
  
and	
  select	
  Group	
  By	
  

Hands on: Viewing variants (VCF file) 
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Select	
  adribute	
  super_pop	
  

Hands on: Viewing variants (VCF file) 
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Scroll	
  down	
  to	
  
see	
  all	
  groups	
  

Hands on: Viewing variants (VCF file) 
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Hands on: Viewing variants (VCF file) 
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Tools 
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Tools 

•  Pre-processing data with igvtools  

•  Combining numeric data tracks 

•  BLAT 
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igvtools 

count 
-  Computes alignment coverage from BAM files  
-  Produces TDF or WIG files 

toTDF 
-  Converts sorted data file to binary tiled data (TDF)  
-  Supported file formats:  WIG, bedGraph 

sort 
-  Sorts file by genomic start position.  
-  Supported file formats:  BED, GFF, GTF, PSL, VCF 

index 
-  Creates index for large genomic annotation files.  
-  Supported file formats:  BED, GFF, GTF, PSL, VCF 

A set of utilities for preparing large files for efficient display.  
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igvtools: count 
 
count transforms alignment files to  

 read coverage files in TDF or WIG format. 

Alignments Read coverage 
(BAM format) (TDF format) 

igvtools	
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igvtools 

(A) Launch from the IGV menu  

      Tools > Run igvtools… 
 
or 
 
 

(B) Run from the command line 
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Combining numeric data tracks 
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Combining numeric data tracks 

Select Tools > Combine Data Tracks 
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Combining numeric data tracks 

1. Select two tracks from 
the dropdown menus 

2. Select operation: 
•  Add 
•  Subtract 
• Multiply 
• Divide 

3. Name the new combined track 
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Combining numeric data tracks 

Track A 

New track = A + B 

Track B 
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BLAT 

•  Use a BLAT server to do search for 
alternative alignments for  
o  any feature or sequence read, or  
o  user-entered sequence. 

•  User-specified server or  
  UCSC  (volume limits apply). 
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BLAT example 
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BLAT example 

Investigate this peak 
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BLAT example 

Investigate this peak 
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BLAT example 

Right-click on a read and 
select BLAT read sequence 
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BLAT example 
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BLAT example 

Many alternative alignments 
with similar scores 
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igv.js 
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JavaScript	
  
version	
  

www.igv.org	
  

igv.js	
  is	
  for	
  developers	
  
who	
  wish	
  to	
  embed	
  
IGV	
  in	
  their	
  web	
  
applica2ons	
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Example	
  of	
  web	
  applica2on	
  that	
  uses	
  igv.js:	
  
ExAc	
  browser	
  from	
  the	
  Exome	
  AggregaHon	
  ConsorHum	
  
(exac.broadins2tute.org)	
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Example	
  of	
  web	
  applica2on	
  that	
  uses	
  igv.js:	
  
Data	
  portal	
  of	
  the	
  Genotype-­‐Tissue	
  Expression	
  (GTEx)	
  project	
  
(See	
  gtexportal.org)	
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For further information and help 
Workshop slides and data: www.igv.org/workshops/ASHG2016 
IGV web site: www.igv.org 
User forum: groups.google.com/group/igv-help 
Source code: github.com/igvteam 

Please cite your use of IGV 
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