IGV Hands-on Exercise IGV Basics
1. Launch IGV
2. Select reference genome. File Genomes View Tracks Reg
* Click on Human hg19 in the genome o060
drop-down menu in the upper left corner. ===——3| {umanhg19 B | s

If you only see Human hg18 in the
menu, it’s ok to select that instead

3. Load data from the IGV hosted server.

* Select File > Load from Server...

* Open the Tutorials menu
(Use@ on Mac, and on Windows)
and click on the Ul Basics checkbox.

Make sure you only open
the Tutorials menu. Do
not check the box next to
Tutorials. That will select
everything under
Tutorials, but we only
want Ul Basics for this
exercise.

p26.1 p24.

Iiﬂu Genomes View

Load from File...

\ Load from URL...
Load romoAS...
Load from Ga4gh...

New Session...
Open Session...
Save Session...

Save Image ...

Exit

If this is the first time
you run IGV, there may
be only one entry in the
menu. More about that
later...

Available Datasets

vvyyy

Available Datasets
Annotations
The Cancer Genome Atlas (@)
ENCODE
Body Map 2.0 (Illumina HiSeq)
1000 Genomes (@
Tutorials

v WI Basics (Encode)

GM12878 H3K27ac
GM12878 H3K27me3
GM12878 H3K36me3
GM12878 H3K4mel

> RNA-Seq (Body Map)
> Variants (1000 Genomes)

Four tracks are loaded: ENCODE project ChIP-seq data representing histone modifications.
Each track is displayed as a bar chart of signal intensities.
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This type of data is perfect for a Ul
basics exercise because the tracks
are visually simple — but the
navigation basics are the same no
matter what type of data you load.
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4. Navigate across different genomic loci and at different zoom levels, from whole genome view
and down to base-pair resolution.

4a. Start at whole genome view:
* Select All from the chromosome drop-down menu —OR- Click the Home button.

e0e@ / Iav /
| Human hg19 sC1 Al C Gu@ > @ W o= 2 | =]
Ruler displays all
the Chromosomes T 1 o 3 4 5 o 7 A 9 . 1 . 13 o 15 T 17 . 19 o 2122 X % -r
| | 1 | 1

‘GM12878 H3K27ac

L

GM12878 H3K27me3

‘GM12878 H3K36me3

s
fmama
[P —
{2

GM12878 H3K4me1

2de o n . i

-

RefSeq genes

mtmm_uim_&mmmhum&‘mldmI“L“' sl o ‘ |

fraces T At this zoomed out
view, the gene track

displays gene density

4b. Zoom in to view one whole chromosome:
* Select Chrl from the chromosome drop-down menu —OR- Click the 1 in the genome ruler.

| Human hg19 = @¢ . . ;
2 4 N 6
| | | I I |
o [ ] IGV
BRE: s chrl Gol Bt « » & MO ® 2 | S =]
Genome ruler now =

has more details and
a cytoband view of =
the chromosome

p31.1 p222 p21.2 pl32  qll q12 q211 q231 q242 q253 q313 q322 q41 q42.2 q

246 mb
120 mb

©-29
‘GM12878 H3K27ac
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IS I SRR W
0-25
GM12878 H3K27me3 J
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GM12878 H3K36me3 |
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GM12878 H3K4me1
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RefSeq genes
L1 PDPN ID3 BAI2 RLF FAF1 NFIA NEGR1 TTLL7 DR1 RNPC3 SYT6
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ANKRD20A12P IFI16 XCL2 TOR3A RGS18 CHIT1 SMYD2 NVL COA6 KIF26l

6 tracks hhr1:59,565.673 Gene track starts
showing individual
genes, but still too

many to see
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4c. Zoom in further:
* Click and drag to zoom in on a region swept out in the ruler

p36.23 p36.12 p34.3 p33 p321 p31l.1 p22.2

nb

* Double-click in the data track to zoom in on a point of interest. [Alt-click to zoom out]

P N T S
[0-25]

hdald b o e bl ot b s ae

[0-25]

Ruler measurements and a red box on the cytoband diagram show where you are in the chromosome

p31.1 p22.2 p21.2 pl13.2

qll ql2 q21.1 q23.1

q24.2 q25.3

23 mb

4d. Move around within the chromosome:
* Jump to another region in the same chromosome (no change in zoom level):
Click anywhere in the cytoband diagram.

* Scroll across genome coordinates: Click anywhere in the data panel and drag left & right.
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0-25] o
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[0- 25]
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4e. Navigate to specific locus or gene on any chromosome
* Type into the search box in the IGV toolbar and click Go:
either a locus in genomic coordinates (e.g. chr1:144,874-969,268) or a gene name (e.g. NRAS)

B
ft « » @O x Q2 | Enngn /=
2 p132  qil qi2 q21 q230 q242  q253 q3L3 q322 qdl  qd22  q#A
16 kb
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1 1 1 1 1 1 1 1 1 1 1 1 1 |
0-25
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4f. Zoom in to base-pair resolution:

* Keep zooming in as before, or click on one of the rightmost ticks on the
“railroad track” zoom widget in the upper right corner.
[ ] [ ] IGV
| Human hg19 3| | chrl 4| lchr1:115,054,888-115,054,968 | Go T < » @5 A = 2 IE' LT ”Il i
p36.23 p36.12 p343 p33  p321 p3l.1 p22.2 p21.2 p132 qll ql2 q21.1 q231 q24.2 q25.3 q31.3 q322 q41 q42.2 q¥
( 81 I:lpl
15,054,890 bp 115,054,900 bp 115,054,910 bp 115,054,920 bp \A‘Gw bp 115,054,940 bp 115,054,950 bp 115,054,960 bp 114
| | | | | | | | | | | | | | | |
-2
GM12878 H3K27ac
-2 - — —
[0-25 - — -
[ | | | |
-2
Sequence =) AGCCATCAGGAAGCCATAAGTACAAGCTCACCTTCTAATGGGAGTGGATGGGTATTTTATCCTGATACATGACCTAGTGA Reference
- sequence
|6 tracks hhrﬂ 15,054,902 EBBM of 430M |
5. Options for viewing the reference sequence track
* Click anywhere on the sequence to show/hide a 3-frame translation
L 111
Sequence [ d AGGTCAGGAGTC
* By default, the sequence for the forward strand is shown.
Click on the arrow to reverse the strand.
L N |
Sequence (V]JCTCCAGTCCTCAGA
6. Options for viewing the gene track and other annotation tracks Exons
IGV uses a UCSC browser style gene representation: \\
N Y N N Y l N l L l N l N N l N l
@ ' 2 | LA B I . I @
- / LANCL2 ,
5" UTR Intron 3" UTR
Features are drawn in a b 55 9
single line, by default EGFR  EGFR
' HHHHH-H-—HE
RefSeq genes. i
Rename Track... EGFR
. | ChangeTrackCo_lor.!., 1]
* Expand the track using the | Cor ke o HAHHH-H-H—HE
right-click popup menu ™y, gee H-iHHHH
Squished EGFR
Copy Details to Clipboard Ll I“I"IH
Use Squished for an even it EGrR B
more compact view | SetFeature Visibility Window... = I I.“.l
Save image... EGFR
Export Features... —
Export track names...
Remove Track
IGV Basics -

END OF EXERCISE
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IGV Hands-on Exercise Load genome from file

1. Clear out the data from the previous exercise: Select File > New Session

2. Select Genomes > Load Genome from File

m View Tracks Regio Note: this is the Genome menu, not the File menu

‘ | Load Genome from File... I ‘
oad Genome from '

Load Genome From Server...

Create .genome File...

Manage Genome List...

[ . The chri.fasta file
and browse to the igvData workshop folder, and contains chromosome 1
then to the genome subfolder and open chrl.fasta from Human hg18.

3. Note in the IGV window: there is no gene track, and no cytoband ideogram in the genome ruler.

IGV hosted genomes package everything together, but you loaded only the FASTA file with the
sequence. You can zoom in and out as before, and enter the numeric value of a locus, but you
cannot find a gene locus by entering the name in the search box.

4. Load a gene annotation track
Select File > Load from File Note: this is the File menu, not the Genome menu

and open refSeq_chr1.bed from the igvData / genome folder.

Now you can jump to a locus by entering the name of a gene on chrl in the search box, e.g. CAP9

Not part of this exercise:
You can use the UCSC Table Browser to get a file of gene annotations.

) Genomes Genome Browser  Tools Mirrors Downloads My Data Help About Us

Table Browser

Use this program to retrieve the data associated with a track in text format, to calculate intersections between tracks, and to retrieve
DNA sequence covered by a track. For help in using this application see Using the Table Browser for a description of the controls in this
form, the User's Guide for general information and sample queries, and the OpenHelix Table Browser tutorial for a narrated presentation
of the software features and usage. For more complex queries, you may want to use Galaxy or our public MySQL server. To examine
the biological function of your set through annotation enrichments, send the data to GREAT. Send data to GenomeSpace for use with
diverse computational tools. Refer to the Credits page for the list of contributors and usage restrictions associated with these data. All
tables can be downloaded in their entirety from the Sequence and Annotation Downloads page.

clade: Mammal B genome: Human ) assembly: Mar. 2006 (NCBI36/hg18) )

group:  Genes and Gene Predictions ) track: RefseqGenes §J  addcustomtracks | track hubs
table: refriat B describe table schema

region: © genome ' ENCODE Pilot regions " position chr1:1-247249719 ookup  define regions
identifiers (names/accessions): pastelist  upload list

filter: create

intersection: create

output format:  BED - browser extensible data [ Send output to ) Galaxy. GREAT () GenomeSpace
output file: refseq_chri.bed (leave blank to keep output in browser)

file type returned: @ plain text " gzip compressed

http://genome.ucsc.edu/cgi-bin/hgTables

get output summaryj/statistics

5. The cytoband cannot be loaded separately into the genome ruler.

END OF EXERCISE







IGV Hands-on Exercise Viewing SNPs

1. Reference Genome

First make sure the reference genome is set to the one you loaded in the previous exercise:
Select chrl.fasta from the genome dropdown menu chrl fasta E
—

2. Load data
Click File > Load from File

Navigate to the workshop igvData folder,

and then the snps subfolder. Open the following files
igvData / snps / snp_calls.bed
igvData / snps / NA12878.SLX.sample.bam

o IGV automatically finds the index file
Note: Do not load the .bai file — as long as it is named correctly and

is in the same folder as the .bam file

IGV

3. Navigate to first putative SNP locus

snpl Go ‘/l'j‘

Type snpl in the search box and click Go

4. Optional

a) Modify the info popup behavior if you b) For alarger data panel, click &
don’t want the yellow info window visible drag the window divider
all the time =» Click on the yellow balloon ’
icon, and select Show details on click

| |
iTi
iTi
| |

—

Sample = NA12878 —
- @? [n] H AL }Raer;dpgerouzt ERRO01757 G C G A G T CC C G
; """"""""""" L K G

‘Read name = IL10_385:6:180:155:338 A

Location = chr1:9,718,629 CLSTN1
‘Alignment start = 9,718,628 (-)

Cigar = 36M | ]

ql2 q21.1 q23.1 q24.2 Mapped = yes

Mapping quality = 70

Pair start = chr1:9718480 (+)
Pair is mapped = yes

Insert size = -184

‘ Pair orientation = F2R1

Viewing SNPS: page 1 First in pair




5. Sort the mismatched aligned reads by base

First, click and drag to position the mismatched bases

between the center guidelines

Right-click (on Mac: control-click) anywhere
in the aligned reads, and select Sort alignments by > base

WGS Alignments

1

Rename Track...

i
i
i
Copy read details to clipboard i

T
T
i

>

= Sortalignments by

start location
read strand

By

>
>
-

v Shade base by quality
v Show mismatched bases
Show all bases

6. See the allele counts and frequencies

Mouse over the red/blue bar in the coverage track
(Or click on the bar, if you changed the information
popup behavior to display on click only)

Observe the distribution of mismatches at that locus.
Observe the lack other mismatches in the region.

=>» This appears to be a heterozygous SNP.

v
N

cccc

; ;otal count: 43

A 1(2%, 0+, 1-)

T
T
T
T

-

C:17 (40%, 10+, 7-)
G-

T
N

:0
125(58%, 13+, 12-)
:0

7. Go to the locus of the second putative SNP

Type snp2 in the search box and click Go

Observe the mismatched bases and their apparent low qualities.

(Mismatched bases are drawn in a fainter color
if the base call is of low quality)

8. Disable shading by quality
Click & drag to position the snp2 locus

(with the 5 blue Cs) between the vertical center guidelines.

Right-click (on Mac: control-click) anywhere in the
aligned reads, and click Shade base by quality

Observe the mismatched bases.

Viewing SNPS: page 2
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9. Sort and color the aligned reads by read strand

Right-click (on Mac: control-click)

anywhere in the aligned reads, and
select Sort alignments by > read strand ; e Ee g

Right-click (on Mac: control-click)
anywhere in the aligned reads, and
select Color alignments by > read strand

Observe where the mismatches are.

AGTATCGGGGAGATGAC CTACGCALCAGC CGCACGCTCGCTGACGCCTAG GG GA

Note: We know that this sequencing was not with a
strand-preserving library, so the expected strand distribution is 50-50.

=> This is likely a false positive.

END OF EXERCISE
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IGV Hands-on Exercise Pre-compute coverage track

This exercise assumes the following have already been loaded in the previous exercises:

a) Reference genome chrl.fasta
(from exercise “Load genome from file”)

b) BAM file from workshop folder: igvData / snps / NA12878.5LX.sample.bam
(from exercise “Viewing SNPs” )

1. First, zoom all the way out by clicking on the leftmost tick NRARARIRANANARRNANAn |
on the railroad track in the zoom tool.

Observe there is no data in the coverage track

inb 20 mb 40 mb 60 mb 80 mb 100 mb 120 mb 140 mb 160 mb 180 mb 200 mb 220 mb
| | | | | | | | | | | | | | | | | | | | | |

240 mb

NA12878.5LX.sample.bam Cove|

4[5 GenomeSpace Hel

2. Launch igvtools: click Tools > Run igvtools [ Runigviools.. |

FiNG MOt
BLAT ...
Combine Data Tracks

Gitools Heatmaps >

BEDTool L
3. Run the Count tool 0% &

> Select Count from the Command dropdown menu
> Set the Input File to the NA12878.SLX.sample.bam file in the workshop folder igvData / snps.
The Output File will automatically be set to the same folder, and same name + .tdf suffix

igvtools
”
Input File ﬁJsers/heIga/igvData/snps/NA12878.SLX.sampIe.bam
Output File /Users/helga/igvData/snps/NA12878.SLX.sample.bam.tdf Browse
Genome /Users /helga/igvData/genome/chrl.fasta Browse

> Keep the defaults for all other values.
> Click Run

Wait until you see “Done” in the Messages area, and click Close.

Messages

100.0%
Done

Pre-computing coverage data: page 1




4. Associate the new .tdf file with the coverage track

> Right-click (command-click on Mac) anywhere on the coverage track in the IGV window ...

NA12878.5LX.sample.bam Covel Zoom in to see coverage.

NA12878.SLX.sample.bam Zoom in to see alignments.
NA12878.SLX.sample ham Coverage
Rename Track...
Change Track Color...
Change Track Height...
Change Font Size...

Set Data Range...
Log scale

V Autoscale

+ Show Data Range

Set allele frequencythreshold

Load pre-computed coverage data...

> ... and select Load pre-computed coverage data.

Copy Details to Clipboard

V Show Alignment Track

> Browse to the workshop folder igvData / snps sron s s
and select the file NA12878.5LX.sample.bam.tdf

Save image...
Export track names...

Remove Track

2. Observe the 3 spikes in the coverage track.

246 mb

nb 20 mb 40 mb 60 mb 80 mb 100 mb 120 mb 140 mb 160 mb 180 mb 200 mb 220 mb

240 mb

[ok/ﬁ \‘
NA12878.SLX.sample.bam Cove|

-

The .bam file for the exercise was stripped down and only has data in these 3 regions.

If you zoom in on the leftmost spike, you will see the snp1 locus from the Viewing SNPs exercise.

END OF EXERCISE
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IGV Hands-on Exercise Viewing RNA-Seq Data

1. Set preferences for viewing RNA-seq data

CIle View > PrEferenceS / = v Show Name Panel —_

Set Name Panel Width...
v Show Attribute Display
Select Attributes to Show...
v Show Header Panel

Select Alignments tab __ Reorder Panels... L

\ ™ Goto »

8 B
Ceneral  Tracks  Variants  Chart robes  Proxy lon Torrent  Advanced

Track Display Options

3
On initial load show: Alignment Track Coverage Track Splice Junction Track

Alignment Track Options

Visibility range threshold (kb): 30 Range at which ajfnments become visible

Check Splice Junction Track
2. Load data

Select Human hg19 from the genome dropdown menu  Human (hg19) T

[T
Click File > Load from Server

Open the Tutorials menu (Use[»] on Mac, and[+)on Windows)
and click on RNA-Seq (Body Map)
and then click on OK o Available Datasets

Available Datasets
> Annotations
> The Cancer Genome Atlas (i)
> ENCODE
>
»

Make sure you only open Body Map 2.0 (Illumina HiSeq)

the Tutorials menu. Do 1000 Genomes @
(@ Tutorials
not check the box nextto = .

i . f > Ul Basics (Encode)
Tutorials. That will select v [o/RNA-Seq (Body Map)
everything under Heart
Tutorials, but we only Liver
want RNA-Seq for this > Variants (1000 Genomes)
exercise.

Cancel  (NOKINY

Viewing RNA-Seq data:
page 1



3. Jump to gene SLC25A3
Type SLC25A3 in the search box and click Go

3 7 9
6 8
ZIeO ?Zenomes View Tracks Regions Tools GenomeSpace Help o | SLC25A36 L | |
Human hg19 +] [ chri2 4] |chr12:98,985,403-98,997,778 ”Cu o« » @ [0 x (=TT
Coverage [ dossadbinndid ... ... |
- Y A —| A |—
 —— e — —
Junctions :
v Covera “‘." nbaall oAbt ALLIAY | TNy 1
. B A N
— [ = —
4. Expand gene track to see isoforms
Right-click over the RefSeq Genes track, and select Squished
RefSeq Genes H
zl?%anomex View Tracks Regions _Tools Ger o Help ot Rename Track...
(Humanhglo ¢ [ chri2 8,985,403-98997.778  |Go B <« » @ [ x (2 | Enunnnunhinnn & 4

i P e T T | -
==

5. Zoom in on first 3 exons

Click and drag in ruler
region over area shown

Viewing RNA-Seq data:
page 2

Change Track Color...
Change Track Height...
Change Font Size...

v Collapsed H
Expanded !

Squished <

Copy Details to Clipboard
Copy Sequence
Blat Sequence

Set Feature Visibility Window...

Remove Track

Save image...
Export To BED File

800 IGV - Session: [igv_s ion.xml
File Genomes View Tracks Regions Tools GenomeSpace _Help
[ Human hg19 +] [ chri2 ] |chr12:98,985,403-98,997.778 [ Go Bt < » @ [ ® 2 | Bl E




6. Note evidence of alternative splicing.

Observe which isoforms in the RefSeq track are expressed in each tissue.

XeXe) 1GV - Session: i Jigy.session.xml
File _Genomes View Tracks Regions _Tools Help
| Human hg19 ] [ chni2 4] |chr12:98,987,204-98989917 (Go Bt <« » @ [ x 2 | Funununmifnin F
(o
.........
1 [ } l [ | | |
1
I
=
Coversga
| A I (.

7. Zoom back out to view whole gene

Click the back button in the command bar to
zoom out to previous view

8. Open Sashimi plot

Right-click over junction track or alignments and select “Sashimi Plot”

800 1GY - Session: / fon.xml

i

heart

G f <« » @O % 2 | il

Rename Track

3] [ 8997,778
e —— B
P DI DI PR T R

Change Track Color
Change Track Height,

se0s s o o e e
L I I I I !

Change Font Size...

ol ... oo ABea
A -

I8 v Collapsed

Expanded

Squished

Copy Details to Chipboard
Copy Sequence

Blat Sequence l]
Set Feature Visibility Window
Remove Track |~

Autoscale

I
18

Verify both heart and liver are checked, and click OK

Viewing RNA-Seq data:
page 3

Sashimi Plot

Save image
Export Features.

©® O O Select Alignment Tracks

™ heart
@I liver




9. Examine Sashimi plot

=

Bl F

5544
NQDW \

Note:

* Arcs represent reads spanning

1‘0}‘1& S — s/

il

wer

exon junctions

Koot

98986020

* Peaks represent exon coverage

10. Filter out low-count splicing events

Right click over red (heart) track and
select Set Junction Coverage Min.
Enter 50 and click OK.

Repeat for blue (liver) track.

11. Compare with non-filtered view

800

Sl #

(e

2749/’7012

N

4+

R

f&sg
100.

S e S—e— Y

1

(e
—

N —

693

98986020 98989732 98993445 98997158

12. Zoominon 5’ end

Click “+” button 2 times

800

98989732

98993445 98997158

Junction Coverage Display
Set Exon Coverage Max

Set Junction Coverage Min

Set Junction Coverage Max

Set Color

v Show Exon Coverage Data

v Text
Circle
None

| v Combine Strands

Forward Strand

Reverse Strand

Save Image...

EIIIIIIIIIIIIII'IIIIIII

Click-and-drag tracks to the right to
bring the first 3 exons in view.

Sl F

0-4a2) 2836
4 ‘:- —

1002

I

13. Observe the alternative splicing

98987397

of the 3 exon

98988239

98989081 98989923

Viewing

RNA-Seq
data: page 4

END OF EXERCISE




IGV Hands-on Exercise Viewing variants (VCF file)

m Genomes View Tre
1. Load data Load from File...
" Load from URL...
. ) . Load from Server...
Click File > Open Session “  Load from DAS...
Load from ENCODE...

Load from Ga4gh...

Then navigate to the workshop [ it I
fOIder/ igVData / vcf T Seve sesson. =
H Save Image ...
and open vcf_session.xml -
it

2. Observe the different data panels

Hover over the variant sites and the genotypes to see the deta
(If you changed the popup behavior with the [ -] tool, you may

ils.
have to click to see the details)

Observe how the same values in the sample information panel are assigned the same color.
Try clicking on the sample information column headers to sort by attribute.

Sample info

1T o BT pILL @it Qiian aris: aiz1 i aizs AT a2 @it

a3z

180
N P ez et e e P P
N 1 I N L 1 L I L N 1 1 I 1

column headers

e
1 L

LT TR T[0T Variant sites

-

\‘ T
min i
e 1
o | 1

1} I 1
mi

mi
mi

I
]
1
e ]
I
1
I

Sample
information

|
|
min I
1

m 11 LI L 1

& | Genotypes

3. Highlight interesting event in gene APOL1
- Type APOL1:S342G in the search box and click Go

| _APOL1:S342G (o)t « » O o=

A\ 4

- Right-click over genotypes and
select Display Mode: Squished

Viewing variants (VCF file) -
page 1

AAAAA
I T T T R T N L T T R T R R R R TR T LR T T T T
F097 m6000218 mOG10M67  nOIGS 724010 mIAOTIMO  m161S1 m1N1S ATTONNT9 m7INE) midI65 16167 mi176 mi126309 m2012928  m79503d

ALL.apoll.sample.phase3_shapeit2_mvncal|

Rename Track...
Change Font Size...

Color By
v Allele Frequency
Allele Fraction

Group By...

Display Mode
Collapsed

v Expanded

Change Squished Row Height...
Suppress Filtered Sites
Set Feature Visibility Window...

Save image...
Export Features...
Export track names...

Remove Track




3. (continued) Highlight interesting event in gene APOL1

— Right-click over genotypes and select Group By, then select attribute super_pop.

4. Observe differences between groups
Use the scrollbar to scroll down and see

ALL.apoll.sample.phase3_shapeit2_mvnca

Rename Track...
Change Font Size...

Color By
V Allele Frequency
Allele Fraction

Sort By Genotype
Sort By Sample Name
Sort By Depth

Sort By Quality

Group By...

Display Mode
Collapsed
v Squished
Expanded

Change Squished Row Height...
Suppress Filtered Sites
Set Feature Visibility Window...

Save image...
Export Features...
Export track names...

Remove Track

all the groups.

Note that the variants at this locus are
not present in some population groups

and are prevalent in others.

Group tracks by:

T

Group By Attribute

v None
sample
pop

gender r

63bp
t & Jlow womw s 000 sosmnsoom gt sennm .
ﬁ ) i 1 | | 1 1 {
Scroll bar
I H = ’
..... =

il

AAAAA

END OF EXERCISE

Viewing variants (VCF file) -

page 2



	IGV_Exercise_1_IGVBasics
	IGV_Exercise_2_LoadGenome
	IGV_Exercise_3_SNPs
	IGV_Exercise_4_igvtools
	IGV_Exercise_5_RNASeq
	IGV_Exercise_6_VariantsVCF

