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Epigenomics

Variants	and	genotypesCopy	number

Microarray	gene	expression
NGS	alignments

RNA-seq

Gene	annotations



IGV supports many different file formats 

For more info see: www.broadinstitute.org/igv/FileFormats
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View remote files without downloading whole dataset

View local files without uploading

Local	files
HTTP	server

FTP	server GenomeSpace

IGV data sources
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www.broadinstitute.org/igv

IGV	is	freely	available	under	an	MIT	open-source	license.
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Using IGV – The Basics



Navigate

Zoom	in	/	out From whole genome view 
to base pair resolution

Scroll	/	pan View neighboring regions

Jump	to	locus Enter coordinates or name

• Select reference genome
• Load data from IGV hosted data server
• Navigate

Hands-on exercise

IGV user interface basics
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Whole 
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Navigate

Whole 
genome

Base pair 
resolution

Hands-on exercise

IGV user interface basics



IGV user interface basics
Hands-on exercise

See handout



More basics – loading data
Other common ways of loading data

• Files > Load from File
• Files > Load from URL



More basics – loading data
Other common ways of loading data

• Files > Load from File
• Files > Load from URL

1) Select Files > Load from URL
2) Enter 

http://www.igv.org/workshops/March2017/signal.tdf
3) Click “OK”

1) In a web browser, navigate to 
http://www.igv.org/workshops/March2017

2) Drag the file signal.tdf and drop it onto the 
IGV window

OR

Try loading from URL:



More basics – track options
Right-click popup menu = track specific options menu

Common options
• Change track name, color, height
• Remove track

For quantitative data tracks: Data Range
• Set to an explicit range
• Enable log scale
• Enable autoscale
• Select multiple tracks and enable “group” autoscale

For quantitative data tracks: Data Display:
• Change between bar chart, line plot, point plot, heatmap
• Select multiple tracks and enable “overlay tracks”



More basics – track options
Right-click popup menu = track specific options menu

Common options
• Change track name, color, height.
• Remove track

For quantitative data tracks: Data Range
• Set to an explicit range
• Enable log scale
• Enable autoscale
• Select multiple tracks and enable “group” autoscale

For quantitative data tracks: Data Display:
• Change between bar chart, line plot, point plot, heatmap
• Select multiple tracks and enable “overlay tracks”



More basics – data details popup

By default, a “data detail” window pops up as the 
the cursor hovers over a data element in a track



More basics – data details popup

By default, a “data detail” window pops up as the 
the cursor hovers over a data element in a track

Change the popup behavior by clicking on the yellow balloon icon.
Options are (1) On hover  (2) On click (3) Never



More basics – the igv folder
In your home folder, IGV creates a folder named igv to store:

igv.log file
• Logs IGV activity and error messages
• If you send us a bug report or help question, we may ask for a 

copy of this file
• To start a fresh log, you can delete or rename this file 

(but not while IGV is running)

prefs.properties file 
• Stores all the preference you set in View > Preferences so 

they are remembered across IGV sessions
• You can reset all preferences by deleting or renaming this file

(but not while IGV is running)

genomes folder
• Stores info about the genomes you’ve loaded – for the 

genomes dropdown menu.



Viewing Multiple Regions



Viewing multiple regions
multi-locus or split-screen view



Viewing multiple regions

Locus	1 Locus	2 Locus	3

multi-locus or split-screen view



Enter multiple loci or features in the search box

Multiple regions – search box



Enter multiple loci or features in the search box

Multiple regions – search box

For a more persistent list of regions, use Regions of Interest



For a more persistent list of regions, use Regions of Interest

To define regions:
(1) Use the Region of Interest tool

- Click on the tool icon in the tool bar
- Click twice in the data panel to specify the region boundaries

Multiple regions – “regions of interest” tools



For a more persistent list of regions, use Regions of Interest

To define regions:
(1) Use the Region of Interest tool

- Click on the tool icon in the tool bar
- Click twice in the data panel to specify the boundaries

(2) Use the Region Navigator
- Navigate to the new region
- Select Regions > Region Navigator
- Click Add to create a region from the current view

Multiple regions – “regions of interest” tools



For a more persistent list of regions, use Regions of Interest

To define regions:
(1) Use the Region of Interest tool

- Click on the tool icon in the tool bar
- Click twice in the data panel to specify the boundaries

(2) Use the Region Navigator
- Navigate to the new region
- Select Regions > Region Navigator
- Click Add to create a region from the current view

(3) Import a file of pre-defined regions
- Prepare a .BED file containing the region definitions
- Select Regions > Import Regions

Multiple regions – “regions of interest” tools



For a more persistent list of regions, use Regions of Interest

To view multiple regions of interest you defined:
Use the Region Navigator

- Select Regions > Region Navigator
- Select 2 or more regions
- Click View

Multiple regions – “regions of interest” tools



To go back to the standard, single-region view:
• double-click on a region label  – or –
• right-click and select Switch to standard view

Viewing multiple regions



more about loading
Reference Genomes



Genome menu

The	genome	drop-down	menu	
is	in	the	upper	left	corner	of	
the	IGV	window.

The	genome	menu	is	short	when	you	first	install	IGV.

But	IGV	hosts	dozens	of	genomes	and	you	can	load	other	genomes	too.



To get more genomes from the IGV server:

More hosted genomes

(1) Select More from the genome menu 
to see the complete list



To get more genomes from the IGV server:

More hosted genomes

(1) Select More from the genome menu 
to see the complete list

(2) Click on entry in the list, 
e.g. Mouse mm10



(3) Optionally select 
Download Sequence

To get more genomes from the IGV server:

More hosted genomes

(1) Select More from the genome menu 
to see the complete list

(2) Click on entry in the list, 
e.g. Mouse mm10

Do	not download	the	
sequence	today!



To get more genomes from the IGV server:

More hosted genomes

(1) Select More from the genome menu 
to see the complete list

(2) Click on entry in the list, 
e.g. Mouse mm10

(3) Optionally select 
Download Sequence

(4) Click OK



Use Genomes menu 
to load genome from 
an indexed FASTA file

Loading other genomes



Use Genomes menu 
to load genome from 
an indexed FASTA file

Loading other genomes

(1) Use samtools faidx command to create .fai index file
See github.com/samtools/samtools for info about samtools

(2) If no index file found, IGV will try to create the index upon load.



Load genome from file
Hands-on exercise

See handout



Load genome from file
Hands-on exercise

This	will	be	the	starting	point	
for	the	next	exercise.



Removing genome from list

Genomes > Manage Genome List



Removing genome from list

Genomes > Manage Genome List

• Remove genomes from list
• Rearrange list
• Add to list

Do	not remove	chr1.fasta	now.	
We’re	using	it	for	the	next	exercise.



Removing genome from list

Genomes > Manage Genome List

• Remove genomes from list
• Rearrange list
• Add to list

Note:	IGV	can	get	confused	if	you	delete	a	local	genome	file	
from	the	file	system	but	not	from	the	IGV	menu



Viewing Next Generation 
Sequencing (NGS) Data



Viewing alignments

Whole chromosome view

Zoom in to see alignments

Coverage



Zoom in to view alignments

Viewing alignments

Aligned 
reads

Coverage



Viewing alignments

Zoom in to see more detail

Bases that do not match 
the reference sequence 
are highlighted by color



Viewing alignments

Coverage track indicates 
loci with large number of 

mismatches



Viewing alignments

Zoom in to see more detail



Viewing alignments

Read mapping quality = 0



Viewing alignments

Zoom in to see more detail

Low-quality base calls are 
faint, semi-transparent.



Viewing alignments

How far do you need to        
zoom in to see the alignments?

30 
kb

-or- Set a different 
threshold in Preferences

• Higher	value	è requires	more	memory	
• Low	coverage	files	è ok	to	use	higher	value
• Very	deep	coverage	files	è use	lower	value

Zoom in to view alignments



Viewing alignments

or limit the depth

For	very	deep	coverage	files:	use	low	visibility	threshold	value

Viewing alignments



Viewing alignments

down-
sampled



• Load alignments from whole genome sequencing
• View sites where SNPs were called
• Sort and color to highlight patterns

Follow along

Viewing SNPs
Hands-on exercise



Viewing SNPs
Hands-on exercise

Click File > Load from File 

Navigate to IGV folder that was 
pre-installed on the computer, 
and then to Data / snps

Open 
NA12878.SLX.sample.bam 
and
snp_calls.bed

Note: This assumes you successfully loaded 
the genome in the previous exercise.

not the .bai file



Viewing SNPs
Hands-on exercise



Viewing SNPs

Type “snp1” in the Search Box and click Go

Navigate to first putative SNP locus

Hands-on exercise



Viewing SNPs
Hands-on exercise



Viewing SNPs
Hands-on exercise



Viewing SNPs

For a larger data panel:
Click & drag the window divider

To modify the info popup behavior:
Click yellow balloon icon in toolbar

Hands-on exercise



Viewing SNPs

Click & drag to 
position mismatched 
bases between the 
center guidelines

Hands-on exercise



Viewing SNPs

Right-click on alignments and select
Sort alignments by > base

On Mac: 
Right-click = Control-click

Hands-on exercise



Viewing SNPs
Hands-on exercise



Viewing SNPs

Mouse over red & blue bar in coverage track. 
Note allele counts and frequencies. 

Hands-on exercise



Viewing SNPs
Hands-on exercise



snp2

Viewing SNPs

Type “snp2” in the Search Box and click Go

Hands-on exercise

Navigate to next putative SNP locus



Viewing SNPs

NOTE:	Large	%	of	low	quality	base	calls,	and	
scatter	of	“C”	mismatches

Hands-on exercise



Viewing SNPs

Click & drag to 
position locus with 
5 blue C’s between 
center guidelines

Hands-on exercise



Viewing SNPs

Right-click on alignments and deselect
Shade base by quality

Hands-on exercise



Viewing SNPs
Hands-on exercise



Viewing SNPs

Right-click on alignments and select
Sort alignments by > read strand

Hands-on exercise



Viewing SNPs

Right-click on alignments and select
Color alignments by > read strand

Hands-on exercise



Viewing SNPs
Hands-on exercise



Viewing SNPs

Reset the color option:
Right-click on alignments and select
Color alignments by > 
insert size and pair orientation

Hands-on exercise



Viewing SNPs



Viewing SNPs



track name=“SNP Calls”

1 9718624 9718625 snp1

1 159464357 159464358 snp2

1 63650225 63650226 snp3

BED file used to define “bookmarks” in SNP exercise

snp_calls.bed



igvtools



igvtools

count
- Computes alignment coverage from BAM files
- Produces TDF or WIG files

toTDF
- Converts sorted data file to binary tiled data (TDF) 
- Supported file formats:  WIG, bedGraph

sort
- Sorts file by genomic start position. 
- Supported file formats:  BED, GFF, GTF, PSL, SAM, BAM, VCF

index
- Creates index for large genomic annotation files and alignments. 
- Supported file formats:  BED, GFF, GTF, PSL, SAM, BAM, VCF

A set of utilities for preparing large files for efficient display. 



igvtools: count

count
transforms alignment files to 
read coverage files in TDF or WIG format.

Alignments
Read coverage(BAM format) igvtools



Coverage track

Coverage track visible before alignments



Coverage track

In our hands-on exercise:
Coverage track was not visible before alignments



igvtools

(A) Launch from the IGV menu 
Tools > Run igvtools…

or

(B) Run from the command line



Pre-compute coverage track
Hands-on exercise

• Use igvtools to compute the coverage for a .bam file
• Associate the new file with the coverage track

Follow along



Coverage track
Hands-on exercise

Click on the left-most tick on the 
zoom ruler to zoom all the way out



Pre-compute coverage track
Hands-on exercise

Click Tools > Run igvtools



Pre-compute coverage track
Hands-on exercise

Select the Count command 
from the dropdown menu

Click Tools > Run igvtools



Pre-compute coverage track
Hands-on exercise

1. Input file: Browse to the Data / snps_morning folder and select the .bam file

2. Output file: Defaults to same folder, and same name + .tdf suffix

3. Other values: Keep defaults

4. Click Run

5. Close window after you see “Done” in the Messages area



Coverage track
Hands-on exercise

2. … and select Load pre-computed 
coverage data from the popup menu

1. Right-click any where 
on the coverage track …

3. Browse to the 
Data / snps_morning folder
and select the file 
NA12878.SLX.sample.bam.tdf



Coverage track
Hands-on exercise



Coverage track
Hands-on exercise

Now

Was



Viewing RNA-seq Data



RNA-seq

http://en.wikipedia.org/wiki/RNA-Seq#Gene_expression



RNA-seq

IGV



RNA-seq alignments

Read spanning 
splice junction



RNA-seq alignments

Splice junction track



RNA-seq alignments

Arcs represent reads that 
span exon junctions

Splice junction track



RNA-seq alignments

Height is proportional 
to number of reads

Splice junction track



RNA-seq alignments

Many reads connecting 
these exons

Splice junction track



RNA-seq alignments

Relatively few 
spanning to this exon

Splice junction track



RNA-seq alignments

Sashimi Plot



RNA-seq alignments

Arcs represent 
reads that span 
exon junctions

Sashimi Plot



RNA-seq alignments

Numbers are 
read counts

Sashimi Plot



RNA-seq alignments

Peaks represent 
coverage within exon

Sashimi Plot



Sashimi plot

Viewing	RNA	splicing	with	Sashimi	Plots

Reference:	

Katz	et	al.
Quantitative	visualization	of	alternative	exon	expression	
from	RNA-seq data
Bioinformatics	(2015)



Viewing RNA-seq data

Examine tissue-specific alternative splicing.

Data:  Illumina BodyMap 2.0

See handout 

Hands-on exercise





Heart

Liver

Viewing RNA-seq data
Hands-on exercise



Coverage

Viewing RNA-seq data
Hands-on exercise



Junction Coverage

Viewing RNA-seq data
Hands-on exercise



Select Squished 
from the popup 
menu to display
isoforms in the 
Gene annotation 
track

Viewing RNA-seq data
Hands-on exercise



Evidence of 
alternative 
splicing

Viewing RNA-seq data
Hands-on exercise



Viewing RNA-seq data
Hands-on exercise

Launch Sashimi Plot 
from the popup menu



Viewing RNA-seq data
Hands-on exercise

Filter and zoom in on 
the first few exons



Viewing Structural Events



Structural events

• Structural	events	include	deletions,	duplications,	translocations,	
and	inversions.	

• Paired	reads	can	yield	evidence	of	structural	events.

• Alignment	coloring	options	help	highlight	these	events	based	on:

• Inferred	insert	size	(template	length)

• Pair	orientation	(relative	strand	of	pair)



DNA or 
cDNA

fragment

read from 
each end

align to 
reference

Paired-end sequencing



DNA or 
cDNA

fragment

read from 
each end

align to 
reference

F R

Paired-end sequencing



DNA or 
cDNA

fragment

read from 
each end

align to 
reference

F R F R F R

Paired-end sequencing



DNA or 
cDNA

fragment

read from 
each end

align to 
reference

insert	size	(or	template	length)

Paired-end sequencing

inferred	insert	size	(or	observed	template	length)



Differences	between	insert	size	and	inferred	insert	size*
can	be	used	to	detect	evidence	of	structural	variants,	
including

• Deletions

• Insertions

• Inter-chromosomal	rearrangements

Interpreting inferred insert size

*	or	template	length	and	observed	template	length



Differences	between	insert	size	and	inferred	insert	size*
can	be	used	to	detect	evidence	of	structural	variants,	
including

• Deletions

• Insertions

• Inter-chromosomal	rearrangements

Interpreting inferred insert size

*	or	template	length	and	observed	template	length
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genome
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B
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reference 
genome
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A
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B
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Deletion
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genome

subject

A
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B
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Deletion



reference 
genome

subject

A

A

B
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Deletion



reference 
genome

subject

A

A

B

B

Deletion



reference 
genome

subject

Inferred	insert	size

Expected	insert	size

Inferred insert size is greater than expected value

Deletion



reference 
genome

subject

Deletion

Pairs with larger than expected insert size are colored red



Deletion

Pairs with larger than expected insert size are colored red



Deletion

Note drop in coverage  

split	screen	view



chr1 chr6reference 
genome

chr1 chr6

subject

Inter-chromosomal fusion



chr1 chr6

subject

reference 
genome

chr1 chr6

Inter-chromosomal fusion



chr1 chr6

subject

reference 
genome

chr1 chr6

Inter-chromosomal fusion



chr1 chr6

subject

reference 
genome

chr1 chr6

Inter-chromosomal fusion



chr1 chr6reference 
genome

Each	read	is	colored	by	the	chromosome	of	its	mate

chr 6	color chr 1	color

Chromosome	colors:

Inter-chromosomal fusion



chr 6chr 1

tumor	
sample

normal		
sample

Inter-chromosomal fusion

split	screen	view



chr 6chr 1

tumor	
sample

normal		
sample

Read color 
indicates 
mate is on 
chr 1

No similar 
evidence in 
the normal 
sample

Read color 
indicates 
mate is on 
chr 6

Inter-chromosomal fusion



Orientation of paired reads can reveal 
evidence of structural events, including:

• Inversions
• Duplications
• Translocations

Interpreting pair orientations



Interpreting pair orientations

Orientation of paired reads can reveal 
evidence of structural events, including:

• Inversions
• Duplications
• Translocations
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Inversion
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Inversion
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genome
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Inversion
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Inversion



reference 
genome
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A B

AB

Inversion



reference 
genome

subject

forward forward

A B

AB

Inversion



reference 
genome

subject

A B

AB

Inversion



reference 
genome

subject

reverse reverse

A B

AB

Inversion



reference 
genome

subject

A B

AB

Inversion



Inversion



Inversion

Note drop in coverage at breakpoints  



Viewing structural events

• Use color and viewing options to examine an inversion
• Data from 1000 Genomes

Follow along

Hands-on exercise



Click	File	>	Open	Session

Navigate	to	the	folder	IGV	workshop	folder /	Data	/	svs
and	select	file	svs_session.xml

Hands-on exercise

Viewing structural events



Hands-on exercise

Viewing structural events



Hands-on exercise

Viewing structural events

Right-click	on	the	alignments	and	select	
Color	alignments	by	>	insert	size



Hands-on exercise

Viewing structural events



Hands-on exercise

Viewing structural events



Hands-on exercise

Viewing structural events



Hands-on exercise

Viewing structural events

Right-click	on	the	alignments	and	select	
Color	alignments	by	>	pair	orientation



Hands-on exercise

Viewing structural events



Hands-on exercise

Viewing structural events

Right-click	on	the	alignments	and	select	
View	as	pairs



Hands-on exercise

Viewing structural events



Viewing Structural Events new



Availability

Features	available	in	IGV	3.0	Beta

See	Other	Versions	on	the	IGV	Downloads	page



Third Gen Sequencing

• Long	reads:		
~10,000	bp up	to	~100,00	bp

• High	raw	error	rate	in	individual	reads	
(high	consensus	accuracy	with	sufficient	coverage)

• Platforms:	
– PacBio,	Oxford	Nanopore



IGV Enhancements

• Filtering	raw	errors	to	reveal	consensus	variants

• Extended	support	for	split	alignments
• Linking	split	reads
• Support	for	“SA”	tag



Filtering raw errors – small indels

PACBIO

ILLUMINA

Aaron	Wenger,	PacBio



Filtering raw errors - indels

PACBIO

ILLUMINA

Aaron	Wenger,	PacBio

Small	indels filtered	
from	view



Filtering raw errors - nucleotides

PACBIO

ILLUMINA

Aaron	Wenger,	PacBio



Filtering raw errors - nucleotides

PACBIO

“Quick	consensus”	mode

ILLUMINA

Aaron	Wenger,	PacBio



Structural variant example - deletion

PACBIO

ILLUMINA

Aaron	Wenger,	PacBio

Deletion	clearly	visible	
in	the	long	reads



3rd gen support enabled in preferences

View	>	Preferences
Alignments	tab

Only	show	consistent	
mismatches

Hide	small	indels

Purple	insertion	labels	



10X

• Long	molecules	are	separated	into	compartments.		
All	molecules	in	same	compartment	share	a	barcode.

• Barcodes	can	be	used	to	reconstruct	molecules	from	
short	read	alignments	(Illumina)



10X

View	linked	reads

IGV enhancements for 10X 



10X

Haplotype	“1”

Haplotype	“2”

IGV enhancements for 10X 



Viewing Variants



Viewing variants (VCF files)

Variant	Call	Format	(VCF):		
File	format	for	encoding	variant	sites	and	genotypes

The	VCF	specification	is	now	maintained	by	the	
Global	Alliance	for	Genomics	and	Health	(GA4GH)	

à Data	Working	Group	à File	Formats	Task	Team	
(http://ga4gh.org/#/fileformats-team)



Viewing variants (VCF file)



Variant	sites

GenotypesSample	
information

Viewing variants (VCF files)

Viewing variants (VCF file)



Viewing variants (VCF files)

Viewing variants (VCF file)



Zoom	in	here

Viewing variants (VCF files)

Viewing variants (VCF file)



Red	=	alternate	allele
Blue	=	reference	allele

Viewing variants (VCF files)

Viewing variants (VCF file)



Viewing variants (VCF file)



Cyan	=	homozygous
Blue	=	heterozygous
Grey	=	reference

Viewing variants (VCF files)

Viewing variants (VCF file)



Viewing variants (VCF files)

Viewing variants (VCF file)



Sample	information
- Meta	data	on	samples.	
- Used	for	sorting	&	grouping

In	this	example:	
• sample
• pop
• super_pop
• gender

Viewing variants (VCF files)

Viewing variants – sample information



Sample	information	is	defined	in	an	auxiliary	tab-delimited	file.

• First	row defines	the	meta	data	column	names

• First	column contains	sample	names	
(must	match	VCF	sample	names)

Example:	

Meta	data	
column	namesVCF	sample	

names

Viewing variants – sample information



Viewing variants (VCF file)

Reference:		

Giulio Genovese	et	al.
Association	of	Trypanolytic ApoL1	Variants	with	Kidney	Disease	
in	African	Americans,
Science	329,	841	(2010);	DOI:	10.1126/science.1193032

Use	sample	information	to	examine	a	variant	that	
segregates	by	population.

Hands-on exercise

See	handout



Hands on: Viewing variants (VCF file)

Viewing variants (VCF file)
Hands-on exercise



APOL1: S342G

In	the	search	box	enter	
APOL1:S342G	and	click	Go

Hands on: Viewing variants (VCF file)

Right-click	over	genotypes	and	select	
Display	Mode	>	Squished

Right-click	over	genotypes	and	select	
Group	By,	and	then	attribute	super_pop

Viewing variants (VCF file)
Hands-on exercise



Scroll	down	to	
see	all	groups

Hands on: Viewing variants (VCF file)

Viewing variants (VCF file)
Hands-on exercise



Hands on: Viewing variants (VCF file)

Viewing variants (VCF file)
Hands-on exercise



Other Tools



Tools

• Combining numeric data tracks

• BLAT



Combining numeric data tracks



Combining numeric data tracks

Select Tools > Combine Data Tracks



Combining numeric data tracks

1. Select two tracks from 
the dropdown menus

2. Select the operation:
• Add
• Subtract
• Multiply
• Divide

3. Name the new combined track



Combining numeric data tracks

Track A

New track = A + B

Track B



BLAT

• Use a BLAT server to do search for 
alternative alignments for 
o any feature or sequence read, or 
o user-entered sequence.

• User-specified server or 
UCSC  (volume limits apply).



BLAT example



BLAT example

Investigate this peak



BLAT example

Investigate this peak



BLAT example

Right-click on a read and
select BLAT read sequence



BLAT example



BLAT example

Many alternative alignments 
with similar scores



For further information and help
IGV web site: www.igv.org
User forum: groups.google.com/group/igv-help
Source code: github.com/igvteam

Please cite your use of IGV
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